[bug-notifications] [gdb 0004690]: "Can't read pathname for load map"

Mantis Bug Tracker noreply at opencsw.org
Wed Feb 16 18:24:16 CET 2011

A NOTE has been added to this issue. 
Reported By:                phil
Assigned To:                pfelecan
Project:                    gdb
Issue ID:                   4690
Category:                   regular use
Reproducibility:            always
Severity:                   block
Priority:                   normal
Status:                     assigned
Date Submitted:             2011-02-15 19:33 CET
Last Modified:              2011-02-16 18:24 CET
Summary:                    "Can't read pathname for load map"
I just tried loading up a program with the new gdb, on a sol9 system
(5.9 Generic_122300-02 sun4u sparc SUNW,UltraAX-i2)

and got the error in the subject line.

This seems to be exactly like 

It makes debugging useless: no stack trace possible.

the problem there is that they suggest "install libc6-dbg", which fixed
their problem.
I have no idea what we should do on Solaris, unfortunately.
btw, I read the README.CSW file, and my shell is /bin/ksh

 (0008798) phil (developer) - 2011-02-16 18:24
oh! hmm.
it sounds like you are saying,
"gdb is just saying, 'cant load debugging symbols'"

but, older versions said pretty much just that, and no more.
It's .. odd.. to see the newer version complain about I/O errors.

Hmm. and in fact, using a more trivial example, where I merely used
"strip" on a program, it does just that:

Reading symbols from [testfile]...(no debugging symbols found)...done.

Hmmm.. experimenting a little more... when I try to just 
[gdb badprog], it merely complains that way.
However, when I specifically try to load it up with the corefile I'm
interested in.. that's when it goes all ga-ga.

I should mention that this was an auto-generated coredump, by means of:

$ coreadm
     global core file pattern: /var/crash/core.%f.%p

Additionally... loading in the thing with dbx instead of gdb, gives a
functional stack trace.

I unfortunately do not know for sure which version of cc it was compiled
with. but the working dbx I tried, is from sun compiler 12.0

More information about the bug-notifications mailing list