[csw-maintainers] serf - how to correctly depend on libapr ?

rupert THURNER rupert at opencsw.org
Sat May 16 20:41:10 CEST 2009

i tried to create a package for libserf, which should replace libneon
in future, as it is able to multithread subversion calls to a server.

as there is no libapr, i tried to depend on apache2 by:

CONFIGURE_ARGS += --with-apr=$(prefix)/apache2
CONFIGURE_ARGS += --with-apr-util=$(prefix)/apache2
#CONFIGURE_ARGS += --with-apr=$(prefix)/apache2/bin/apr-config
#CONFIGURE_ARGS += --with-apr-util=$(prefix)/apache2/bin/apu-config

(see also: https://apps.sourceforge.net/trac/gar/browser/csw/mgar/pkg/libserf/trunk/Makefile

but, for some reason, /opt/csw/bdb44/lib makes it into the compile,
and not /opt/csw/apache2/lib.

gmake[2]: Entering directory
/opt/csw/apache2/share/build/libtool --silent --mode=link
/opt/studio/SOS11/SUNWspro/bin/cc -xarch=386 -L/opt/csw/lib
-L/opt/csw/bdb44/lib -static -o test/serf_get libserf-0.la
test/serf_get.lo /opt/csw/apache2/lib/libaprutil-1.la -lldap -llber
-ldb-4.4 -lexpat -liconv  -lapr-1 -luuid -lsendfile -lrt -lsocket
-lpthread -ldl -lm  -lz -lssl -lcrypto
ld: fatal: library -lapr-1: not found
ld: fatal: File processing errors. No output written to test/serf_get
gmake[2]: *** [test/serf_get] Error 1
gmake[2]: Leaving directory
gmake[1]: *** [build-work/build-isa-i386/serf-0.3.0/Makefile] Error 2
gmake[1]: Leaving directory `/home/rupert/mgar/pkg/libserf/trunk'
gmake: *** [merge-isa-i386] Error 2

what can this be?


More information about the maintainers mailing list