[csw-maintainers] Xlibs regression when building xterm (Xrender.h/Xft.h not found, ...)

Sebastian Kayser skayser at opencsw.org
Tue Sep 22 10:42:32 CEST 2009

Dagobert Michelsen wrote on 22.09.2009 07:52:
> Am 21.09.2009 um 18:39 schrieb Sebastian Kayser:
>> Philip Brown wrote:
>> Thanks for the info, Phil. Update: i worked towards using the  
>> CSWlibx11
>> bits (xterm has --x-includes and --x-libraries ./configure flags, no  
>> need
>> for EXTRA_INC or EXTRA_LIB) and now i am down to some remaining  
>> linkage
>> errors.
>> Undefined                       first referenced
>> symbol                             in file
>> FcCharSetHasChar                    fontutils.o  (symbol belongs to
>> implicit dependency /opt/csw/lib/libfontconfig.so.1)
>> FcPatternBuild                      fontutils.o  (symbol belongs to
>> implicit dependency /opt/csw/lib/libfontconfig.so.1)
>> FcPatternDestroy                    fontutils.o  (symbol belongs to
>> implicit dependency /opt/csw/lib/libfontconfig.so.1)
>> XA_UTF8_STRING                      button.o
>> ^^ Non-wrapped output and cc invocation available on dpaste [1].
>> Sebastian
>> [1] http://dpaste.com/96366/
> I have not seen this before. Maybe a dependency has not been correctly  
> compiled
> in there. Could you please verify where the symbols come from?

Regarding the XA_UTF8_STRING symbol: it comes with a recent [1] libXmu
library (X11 utility library) for which we don't yet have a CSW pkg.

xterm _also_ ships with an implementation of XA_UTF8_STRING, but when it
finds that X_HAVE_UTF8_STRING is defined (set by our Xlib.h), it assumes
the system has an implementation of its own. In our case however, the
system doesn't have have it, thus the build breaks. The stock Solaris
Xlib.h which i used for the build a few months ago, doesn't set
X_HAVE_UTF8_STRING. That's why the build was fine.

Technically, xterm's assumption about the XA_UTF8_STRING presence might
be wrong though, as it only checks for a Xlib UTF8 #define and then
assumes the presence of a libXmu function. Guess i might have to talk to

Still not sure about the Fc* symbol woes.


[1] Solaris 10 has a libXmu version that comes with XA_UTF8_STRING,
Solaris 8 and 9 don't.

More information about the maintainers mailing list