[csw-maintainers] /testing Some X11 proto updates

Dagobert Michelsen dam at opencsw.org
Mon Sep 28 10:57:20 CEST 2009

Hi Maciej,

Am 26.09.2009 um 12:03 schrieb Maciej (Matchek) Blizinski:

> On Sat, Sep 26, 2009 at 9:59 AM, Dagobert Michelsen  
> <dam at opencsw.org> wrote:
>> Hi,
>> Am 25.09.2009 um 19:27 schrieb Philip Brown:
>>> On Thu, Sep 24, 2009 at 1:36 PM, William Bonnet  
>>> <william at wbonnet.net>
>>> wrote:
>>>> Proposition are listed in this poll :
>>>> http://doodle.com/huc5w789f4gmft79
>>> i finally got around to looking at this... and seems like an  
>>> option is
>>> missing.
>>> you were comparing what happens to something called "fooproto".
>>> you give "xfooxproto" as an option (which is very confusing to me,
>>> sticking something in the  MIDDLE). But you dont have "xfooproto" as
>>> an option.
>> William, Sebastian, Maciej: Why do you think it is a good idea to
>> reorder the naming parts of the software? Like
>> inputproto -> x11proto_input
>> And I don't want to hear "for consistency", Maciej ;-)
> Actually, I thought about suggesting compressing the prefix even more.
> We've got pm_* and py_*, right? If there's a whole category of X11
> protocols, why not have xp_*? A counterargument could be that xp_* is
> not self explanatory. Well, neither is pm_*.

It is, because the files end in .pm :-)

> If anyone is interested
> in what those packages are (that xp stands for X11 protocol),
> descriptions will help. What do you think?

The proposed solution from William with a simple prefix and leaving the
rest as defined by upstream sounds very reasonable to me.

Best regards

   -- Dago

More information about the maintainers mailing list