[bug-notifications] [facter 0004924]: Are Facter and Puppet missing a dependency?J

Mantis Bug Tracker noreply at opencsw.org
Wed Mar 21 17:35:17 CET 2012

A NOTE has been added to this issue. 
Reported By:                dcjackson
Assigned To:                
Project:                    facter
Issue ID:                   4924
Category:                   packaging
Reproducibility:            always
Severity:                   major
Priority:                   normal
Status:                     new
Date Submitted:             2012-03-21 01:14 CET
Last Modified:              2012-03-21 17:35 CET
Summary:                    Are Facter and Puppet missing a dependency?J
I am a newbie to opencsw.  Used Blastwave for a long time....

Anyway, I install my OS via JumpStart
Solaris10 u10 x86.

First I install pkgutil, then puppet (within my jumpstart finish script)

I then try to use faster within my finish script, and get this:

/opt/csw/lib/ruby/site_ruby/1.8/facter/util/config.rb:4:in `require': no
such file to load -- rbconfig (LoadError)
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/util/config.rb:4
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/util/resolution.rb:7:in
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/util/resolution.rb:7
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/util/fact.rb:2:in `require'
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/util/fact.rb:2
	from /opt/csw/lib/ruby/site_ruby/1.8/facter.rb:21:in `require'
	from /opt/csw/lib/ruby/site_ruby/1.8/facter.rb:21
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/application.rb:5:in `require'
	from /opt/csw/lib/ruby/site_ruby/1.8/facter/application.rb:5:in `run'
	from /opt/csw/bin/facter:60

This problem also occurs after I reboot the machine and log in.

I then did a pkgutil --install ruby18_gcc4

After that completed, faster worked fine.

I am wondering if puppet/facter are missing a dependency?

Of course, I could be doing something wrong, in general, or WRT installing
this stuff within jumpstart.

 (0009749) dcjackson (reporter) - 2012-03-21 17:35
Just to be clear, at present, I am running two pkgutils in sequence within
my jumpstart finish script:
First I run:
 --install CSWruby18-gcc4
Then I run:
 --install CSWpuppet

After install/reboot, running apps like faster do not work with the error
message above.

# /opt/csw/sbin/alternatives --display rbconfig18
Installed alternatives for rbconfig18 are:
/opt/csw/lib/ruby/1.8/i386-solaris2.9/rbconfig.rb rbconfig18
/opt/csw/lib/ruby/1.8/i386-solaris2.9/rbconfig.rb.sun 5

# ls -l /opt/csw/lib/ruby/1.8/*solaris2.9/rbconfig.rb*
-rw-r--r--   1 root     bin         7325 Mar 24  2011

# head -20 /opt/csw/lib/ruby/1.8/i386-solaris2.9/rbconfig.rb.sun

# This file was created by mkconfig.rb when ruby was built.  Any
# changes made to this file will be lost the next time ruby is built.

module Config
  RUBY_VERSION == "1.8.7" or
    raise "ruby lib version (1.8.7) doesn't match executable version

  TOPDIR = File.dirname(__FILE__).chomp!("/lib/ruby/1.8/i386-solaris2.9")
  DESTDIR = '' unless defined? DESTDIR
  CONFIG = {}
  CONFIG["INSTALL"] = '/opt/csw/bin/ginstall -c'
  CONFIG["prefix"] = (TOPDIR || DESTDIR + "/opt/csw")
  CONFIG["ruby_install_name"] = "ruby18"
  CONFIG["RUBY_SO_NAME"] = "ruby18"
  CONFIG["MANTYPE"] = "man"

If you want additional info, I can change my finish script and re-run it to
get exactly what you want, just let me know....

More information about the bug-notifications mailing list