[squid 0005163]: squid 3.4.4 crashes on Solaris 10

Mantis Bug Tracker via bug-notifications bug-notifications at lists.opencsw.org
Thu Apr 24 00:09:46 CEST 2014

A NOTE has been added to this issue. 
Reported By:                hudesd
Assigned To:                dam
Project:                    squid
Issue ID:                   5163
Category:                   regular use
Reproducibility:            have not tried
Severity:                   crash
Priority:                   normal
Status:                     feedback
Date Submitted:             2014-04-11 23:13 CEST
Last Modified:              2014-04-24 00:09 CEST
Summary:                    squid 3.4.4 crashes on Solaris 10
I have been using Squid 3.1 for quite awhile with no problem. I recently
upgraded all my CSW packages and Squid 3.4.4 came with it, no option
otherwise it's in stable/unstable/testing.
The problem is that it is NOT stable: it exits after awhile.
It's running as a service (cswsquid) as per the package.
This on a T2000 Solaris 10 148888-05 with 8GB RAM and about 600GB of
available disk space .
I had made no change to the configuration between 3.1 and 3.4. I
subsequently have tried both aufs and my original ufs (diskd isn't
available) to no avail.
I increased the size of the disk and memory cache to no avail.
Squid will run happily as long as users are only tunneling through it; once
some caching gets going with regular http it exits.

I'm not finding any core dumps in /var/opt/csw/squid/cache or the 00
directory under that.
I can provide squid config files and log files. 

 (0010809) hudesd (reporter) - 2014-04-24 00:09
Apr 23 13:08:23 Leaving maintenance because clear requested. ]
[ Apr 23 13:08:23 Enabled. ]
[ Apr 23 13:08:23 Executing start method
("/var/opt/csw/svc/method/svc-cswsquid start") ]
starting squid server.
[ Apr 23 13:08:23 Method "start" exited with status 0 ]
2014/04/23 13:08:23| WARNING: -D command-line option is obsolete.
[ Apr 23 16:08:25 Stopping because process dumped core. ]
[ Apr 23 16:08:26 Executing stop method
("/var/opt/csw/svc/method/svc-cswsquid stop") ]
squid server is already down
[ Apr 23 16:08:26 Method "stop" exited with status 0 ]
[ Apr 23 16:09:27 Method or service exit timed out.  Killing contract
8579326 ]

More information about the bug-notifications mailing list