[csw-maintainers] [csw-users] Munin 1.3.4 in testing

Trygve Laugstøl trygvis at opencsw.org
Mon Jul 6 19:28:18 CEST 2009

Trygve Laugstøl wrote:
> Juergen Arndt wrote:
>> On Mon, 06 Jul 2009 18:32:29 +0200, Trygve Laugstøl 
>> <trygvis at opencsw.org> wrote:
>>> Juergen Arndt wrote:
>>>> Hi,
>>>>  I've put Munin 1.3.4 into testing. It's the initial version for 
>>>> OpenCSW. The software consists of the packages munin_master and 
>>>> munin_node.
>>> Also, why was 1.3.4 packaged and not the stable 1.2.6? Is 1.3.4 know 
>>> to be as stable as 1.2.6?
>>> I see that Fedora and Debian both package 1.2.5/.6:
>>> http://dag.wieers.com/rpm/packages/munin/
>>> http://packages.debian.org/search?keywords=munin&searchon=names&suite=all&section=all 
>> 1.2.6 is the last official stable version, but it's already more than 
>> a year old and I was asked to package a more current version. If this 
>> does not comply with our policies, I will package 1.2.6 as well, no 
>> problem.
> No, I was just wondering really.
>>> I just tried your packages. The installation look fine and I made 
>>> some small notes on the wiki[1]. However, when I tried to create a 
>>> graph, all and any letters are rendered as a box. See the attached 
>>> image. I assume that this really is an rrdtool issue more than a 
>>> Munin issue.
>>>  [1]: http://wiki.opencsw.org/munin-package
>> I cannot confirm that, on my installation the graphs look as expected. 
>> Maybe some dependencies are missing, I will try to dig into it.
>> I will update your wiki page in the next future with some more 
>> installation details.
> I think it would be nice if the package included two complete apache 
> configuration files (the basic and the one with CGI) so that the user 
> can just Include them from httpd.conf. From what I can tell it is not 
> likely that a user will need to adjust the configuration at all, at 
> least not to get started.
> As for my rrd issue I just did a test from the rrd tutorial and the 
> graphs look ok there.

I tried to use the CGI version and got a Pango related error:

[Mon Jul 06 19:21:52 2009] [error] [client] (process:6716): 
Pango-CRITICAL **: No modules found:
[Mon Jul 06 19:21:52 2009] [error] [client] No builtin or 
dynamically loaded modules were found.
[Mon Jul 06 19:21:52 2009] [error] [client] PangoFc will not 
work correctly.
[Mon Jul 06 19:21:52 2009] [error] [client] This probably 
means there was an error in the creation of:
[Mon Jul 06 19:21:52 2009] [error] [client] 
[Mon Jul 06 19:21:52 2009] [error] [client] You should create 
this file by running:
[Mon Jul 06 19:21:52 2009] [error] [client] 
pango-querymodules > '/opt/csw/etc/pango/pango.modules'

Which I did and I got this output:

ArabicScriptEngineFc PangoEngineShape PangoRenderFc arabic:* nko:*

Why are there only 64-bit modules there?

Anyway, running the CGI again gave me this:

Pango-WARNING **: ld.so.1: perl: fatal: 
/opt/csw/lib/64/pango/1.6.0/modules/pango-basic-fc.so: wrong ELF class: 


More information about the maintainers mailing list