[csw-maintainers] remove openldap not possible with pkg-get and pkgutil

rupert THURNER rupert at opencsw.org
Sun Jul 19 16:11:19 CEST 2009

i was testing the new source code packages, and i did not pay enough
attention when upgrading. after doing a

pkgutil -t http://mirror.opencsw.org/opencsw/testing -i subversion
pkgutil -t http://mirror.opencsw.org/opencsw/testing -i mercurial

subversion was insisting on finding /opt/csw/lib/libldap-2.3.so.0,
while only /opt/csw/lib/libldap-2.4.so.0 was available. somehow
openldap got upgraded to
openldap_rt-2.4.16,REV=2009.06.29-SunOS5.8-sparc-CSW.pkg.gz from

i tried to remove it or downgrade it, but it did not work with
pkgutil, and pkg-get.

# pkgutil -r CSWoldaprt
Parsing catalog, may take a while...
Looking at installed CSW packages...
Examining dependencies for:
 CSWoldaprt (in use)
 CSWlibnet (in use)
 CSWsasl (in use)
 CSWossl (remove)
 CSWbdb4 (remove)
 CSWossldevel (remove)
 CSWosslutils (remove)
 CSWosslrt (in use)
 CSWcacertificates (remove)
 CSWcswclassutils (in use)
 CSWcommon (in use)
5 packages to remove. Do you want to continue? [Y,n]

# pkg-get -r CSWoldaprt

WARNING:  the remove option is not very intelligent.
If there are multiple versions of a package with the same
PKG style name, it will remove the first one it can
(will continue in 5 seconds)
Starting remove operations now...

ERROR: no matching SysV PKG found.
CSWoldaprt CSWoldaprt
(either you mistyped it, or you need to updatecatalog, or
 it isnt available for your OSREV yet)

then i used pkgrm and pkgutil -u to install it again and it worked.

so i wonder:
* why oldap gets upgraded
* how to remove / downgrade packages


More information about the maintainers mailing list