[csw-maintainers] setxkbmap investigation

Maciej (Matchek) Blizinski maciej at opencsw.org
Wed Jul 29 12:16:18 CEST 2009

On Wed, Jul 29, 2009 at 7:46 AM, Dagobert Michelsen<dam at opencsw.org> wrote:
> Hi Maciej,
> Am 29.07.2009 um 01:16 schrieb Maciej (Matchek) Blizinski:
>> I have a reference binary in /var/tmp, which reads the keymap from a
>> known location: /usr/X11/lib/X11/xkb/symbols. For instance, when I run
>> 'setxkbmap pl', the file /usr/X11/lib/X11/xkb/symbols/pl gets read.
>> When I run my setxkbmap, they 'pl' keymap must get loaded from
>> someplace else, because it's not my (patched) keymap. But I can't
>> figure out, where it is being read from.
> You can try "opensnoop" from the dtracetoolkit (pkg-get -i dtracetoolkit):
> root at ncsw [global]:/root > opensnoop
>  UID    PID COMM          FD PATH
>    0  16783 mibiisa        2 /dev/kstat

I installed the dtracetoolkit, thanks! opensnoop is really useful.

http://dpaste.com/72855/ -- looks like it's the .../pc/pl file that
gets loaded by xkbcomp.

> However, setxkbmap doesn't work in my environment:
> dam at build10st [build10st]:/home/dam > setxkbmap pl
> Couldn't interpret _XKB_RULES_NAMES property
> Use defaults: rules - 'xorg' model - 'pc101' layout - 'us'
> Error loading new keyboard description
> zsh: 5047 exit 251   setxkbmap pl

Perhaps X11 packages aren't installed.

Thanks for the help. I'll poke it some more to if I can get it to load
the correct keyboard mapping.


More information about the maintainers mailing list