[csw-maintainers] Revisiting the GCC4 Undefined symbol __sync_fetch_and_add_4 nonsense

Dagobert Michelsen dam at opencsw.org
Tue Oct 19 14:54:53 CEST 2010


Am 13.10.2010 um 14:42 schrieb Maciej (Matchek) Blizinski:
> No dia 13 de Outubro de 2010 13:33, Dagobert Michelsen
> <dam at opencsw.org> escreveu:
>>>> Roger mentioned that he tweaked the compiler options for GCC4 from
>>>> -mcpu=v8
>>>> to -m32. I tried this but checkpackage whined that all of my  
>>>> binaries and
>>>> libraries were compiled for v8+ instead of v8 and wanted them in
>>>> arch-specific sub directories.
>>> Is a hardware instruction present in sparcv8+, and not in sparcv8?
>>> Does anyone know?
>> BTW, I am having this same exact error on libtag_gcc now :-(
> Is the sparcv8 support worth the trouble?

I finally found the issue: this can happen if you define any  
level > 0. Skipping -O* or using -O0 works and the problem is gone. I
tried to find the specific flag combination triggering the issue but
failed to do so. The current progress is documented at
However, it should be sufficient to continue with the stopped
packaged with this workaround.

Best regards

   -- Dago

More information about the maintainers mailing list