[csw-maintainers] package naming conventions for addons to other packages

Kester Habermann kester at bender.opencsw.org
Wed Oct 27 10:49:04 CEST 2010


I wanted to package django-auth-ldap[1] which is an package that may
be using together with Django. I come up with the following name:
  GARNAME = django-auth-ldap
  PACKAGES = CSWpy-django-auth-ldap
  CATALOGNAME = py_django_auth_ldap
checkpkg tells me the name is too long and suggests using
CHECKPKG_OVERRIDES_CSWpy-django-auth-ldap += pkgname-too-long

Any suggestions on how to name such packages to indicate
that they are an extension to something else. Or should
I just put in the override?

Best Regards


[1] http://pypi.python.org/pypi/django-auth-ldap/

More information about the maintainers mailing list