[csw-maintainers] package naming conventions for addons to other packages

Peter FELECAN pfelecan at opencsw.org
Wed Oct 27 11:54:01 CEST 2010

Kester Habermann <kester at bender.opencsw.org> writes:

> Hello,
> I wanted to package django-auth-ldap[1] which is an package that may
> be using together with Django. I come up with the following name:
>   GARNAME = django-auth-ldap
>   PACKAGES = CSWpy-django-auth-ldap
>   CATALOGNAME = py_django_auth_ldap
> checkpkg tells me the name is too long and suggests using
> CHECKPKG_OVERRIDES_CSWpy-django-auth-ldap += pkgname-too-long
> Any suggestions on how to name such packages to indicate
> that they are an extension to something else. Or should
> I just put in the override?

The issue is with the package name, i.e., CSWpy-django-auth-ldap, which
is longer that the current, arbitrary, limit on package names. Using the
override is an useful kludge but not a definitive/final solution. As we
discussed earlier, we must relive all arbitrary limits an conform to the
reality of the underlying package system. However, as so often, that
discussion was drown in noise and the status quo is maintained for a
dubious aesthetic consideration.

More information about the maintainers mailing list