[csw-maintainers] Problems upgrading

Jeffery Small jeff at cjsa.com
Thu Apr 5 12:48:07 CEST 2012

In an attempt to get the latest version of samba, I knew I would regret the
upgrade process!

I'm upgrading from "current" on my SPARC Solaris 10 machine.

Things really started to fall apart during the upgrade as all sorts
of changes began to break the ability for the upgrade to continue.
I've solved a number of problems, such as sendmail being left in an
unusable state due to the directory shuffle from /opts/csw/{etc,var} to
/{etc,var}/opt/csw. Finally, downloads of new packages came to a crawl.
There seems to be a serious authentication problem with the relocation of
the openssl files.  I have:


and there are now sumlinks under /opt/csw/etc that point to these.  There
are also links under /optcsw/ssl which point all over the place but
eventually resolve in /etc/opt/csw/ssl.

However, fetchmail is now spewing out a stream of the following:

        fetchmail: Server certificate verification error: unable
        to get local issuer certificate fetchmail: This means that
        the root signing certificate (issued for /C=GB/ST=Greater
        Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO High-Assurance
        Secure Server CA) is not in the trusted CA certificate locations,
        or that c_rehash needs to be run on the certificate directory. For
        details, please see the documentation of --sslcertpath and
        --sslcertfile in the manual page. fetchmail: Server certificate
        verification error: certificate not trusted fetchmail: Warning:
        the connection is insecure, continuing anyways. (Better use

I have tried running c_rehash (which still references "/opt/csw/ssl") but
this has not improved anything.

Any suggestions how to calm this beast?



C. Jeffery Small           CJSA LLC                       206-232-3338
jeff at cjsa.com              7000 E Mercer Way, Mercer Island, WA  98040

More information about the maintainers mailing list