[csw-users] Outdated packages e.g. GCC 4.3 instead of 4.6 - reason? ; Suggestion new packages?
maciej at opencsw.org
Mon Aug 1 18:07:16 CEST 2011
2011/7/29 Paul Lanken <lanken.paul at gmail.com>:
> blastwave has 4.6.1 I think .. at least that is what the GCC site says
I looked at their new catalog (bwstack), but couldn't find the gcc
packages. There was libgcc, but not the compiler itself. libgcc is at
I took a stab at gcc-4.6.1 and got the following error:
configure: error: Building GCC requires GMP 4.2+, MPFR 2.3.1+ and MPC 0.8.0+.
I believe we have GMP 4.2.2 and MPFR 3.2.1 in the catalog. However, I
found this bit of code in the GCC config.log:
#if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,3,2)
...so it really checks for GMP version 4.3.2 or higher. We also don't
have MPC, and MPC requires the same version of GMP: 4.3.2 or higher.
We'll need to build it first. If I make any progress, I'll submit
my code changes to the repository.
More information about the users